DIY Ganganzeige für alle 690iger Modelle

  • Hi Leuts!


    Da es momentan eh etwas fad ist im Forum und einige vermutlich auch schon ihr Moped in den Winterschlaf geschickt haben, und noch nicht recht wissen was sie übern Winter basteln sollen, dachte ich mir ich zeig euch mal wie man die, meiner Meinung nach perfekte Ganganzeige für round about 20€ selbst baut.


    Ich sag's gleich, die Idee dazu stammt nicht von mir, sondern ich bin durch masterreset auf diese Seite aufmerksam geworden.


    Ich hab zwar schon eine Ganganzeige nach dem Hall Prinzip an meinem Bike montiert, aber da die trotzdem auch ihre Schwächen hat und ich die Idee, den vorhandenen Gangsensor zu erweitern und für eine Ganganzeige zu nutzen, so unglaublich grenzgenial gefunden hab dass sie mir auch nicht mehr aus dem Kopf gegangen ist, hab ich mich heute einfach mal an die Arbeit gemacht, mir auch so eine Ganganzeige zu basteln.


    Dazu hab ich mir heute als erstes einfach mal auf AliExpress ein Display für eine Ganganzeige bestellt.


    Es werden auf AliExpress, Amazon, etc. verschieden Displays für Ganganzeigen angeboten. Welches ihr kauft ist dabei grundsätzlich egal, aber passt auf das ihr auch wirklich eine für 6 Gänge kauft und nicht eines welches dann lediglich 5 Gänge anzeigt!


    So, dann den Gangsensor am Moped abschrauben.

    Für jene die nicht wissen wo der ist, der sitzt am Motorgehäuse zwischen Ritzel und Schalthebel:


    20191019_215728.jpg


    So schaut der ausgebaut aus:


    20191019_220123.jpg


    20191019_220106.jpg



    An der Vorderseite sieht man die 4 originalen Kontakte:


    20191019_220834.jpg


    Der Punkt in der Mitte ist die Masse über die dann der Strom fließt sobald ein Gang eingelegt ist.

    Der kleine Kontakt ist für den Leerlauf und die zwei anderen Kontakte sind der 2te Gang und der 3te Gang.


    Somit sind bereits 4 Kontakte ab Werk vorhanden, fehlen noch 4 Kontakte (1 - 4 - 5 - 6)


    Wenn man den Gangsenor im richtigen Winkel gegen das Licht hält, dann kann man ganz deutlich die Abdrücke erkennen, wo der Pin im Getriebe bei den anderen Gängen zum stehen kommt:


    20191019_213807.jpg


    Die 2 Pins im Getriebe (1x PIN für die Masse und 1x Pin für die Gänge) sehen übrigens so aus und sind nicht starr, sondern drücken, vorgespannt durch eine kleine Feder, auf den Gangsensor:


    20191019_222009.jpg



    So, wo bekommen wir jetzt die fehlenden Kontakte her?

    Dazu gibt es sicher mehrere Möglichkeiten, aber ich zeig euch einfach mal wie's ich gemacht habe.


    1.) Dort, wo man die Abdrücke erkennt, mit einem 1mm Bohrer einfach mal leicht anbohren:


    20191019_200237.jpg


    Ich hab den 1mm Bohrer mit Malerkreppband umwickelt, sonst hätte ihn das Bohrfutter meiner Bohrmaschine nicht gespannt.

    Bitte die Stellen nicht körnen oder so, denn sonst springt euch möglicherweise der Gangsensor oder bekommt Risse!


    Nachdem ich die Punkte mit dem 1mm Bohrer exakt gekennzeichnet hab, hab ich mit einem 2,5mm an diesen Stellen durch den Gangsensor durchgebohrt.


    Bei einem Punkt muss man aufpassen (4ter Gang), da dort hinten am Gangsenor die originalen Kabel verlaufen. Also aufpassen dass ihr dort nicht in die Kabel reinbohrt oder diese beschädigt!

    Wenn man ganz exakt gerade bohrt, dann sollte es sich schön ausgehen ohne das man ein Kabel anbohrt.


    Ich Vollpfosten hab aber natürlich genau dieses Loch windschief gebohrt und hab dabei dann auf der Rückseite das Massekabel gestreift 🤷🏼‍♂️


    20191019_223720.jpg


    War aber zum Glück nicht tragisch, trotzdem hätte ich mich am liebsten Ohrfeigen können dafür 🤦🏻‍♂️




    Als ich dann alle 4Löcher mit dem 2,5mm Bohrer durchgebohrt hatte, hab ich auf der Vorderseite die Löcher mit einem 4mm Bohrer ganz leicht angesenkt:


    20191019_204152.jpg


    Dann hab ich 3x20mm Messing Holzschrauben mit Schlitz (~6€ im Baumarkt) genommen und diese in die Löcher eingedreht.

    Der Schafft dieser Schrauben hat 2,7mm Durchmesser, also dichtet er das auf 2,5mm gebohrte Loch dann auch perfekt ab


    20191019_203748.jpg


    Zusätzlich hab ich aber die Schrauben natürlich auch noch ordentlich mit Loctite 243 eingeklebt.

    Bitte die Schrauben nicht zu fest eindrehen, sonst bricht der Gangsensor oder bekommt einen Riss!! Die Schrauben wirklich nur sehr gefühlvoll mit geschätzten 4-5NM eindrehen!

    Ihr könnt euch sicher sein dass vorher der Gangsensor springt oder einen Riss bekommt, bevor die Schraube durchdreht! Also die Schrauben wirklich nur ganz putschasti (=vorsichtig) festziehen!


    So sieht das dann aus wenn alle Schrauben drinnen sind:


    20191019_205649.jpg


    Schaut doch schon mal ziemlich Kacke aus würd ich sagen, oder? :kacke: 🙈 :grins:



    Also hab ich angefangen die Schraubenköpfe mit dem Dremel vorsichtig abzuschleifen:


    20191019_210443.jpg


    Das geht relativ einfach, da Messing ja verhältnismäßig weich ist und so waren alle 4 Schrauben dann innerhalb von 10min. halbwegs plan geschliffen.

    Zum Schluss hab ich dann noch mit einem Ölstein alles wirklich komplett plan abgezogen.

    Man kann aber auch einfach feineres Schleifpapier auf einen ebenen Untergrund legen und den Gangsensor umgedreht darauf plan schleifen wenn man keinen Ölstein zu Hause hat.

    Der Sensor muss übrigens auch nicht zu 100% plan sein, da die Pins im Motorgehäuse ja eh flexibel sind. Also selbst wenn der Sensor/die Schraubenköpfe nicht zu 100% plan sind, wird die Anzeige trotzdem funktionieren.


    Und so sieht mein fertiges Ergebnis aus:


    20191019_212732.jpg


    20191020_003259.jpg


    Passt würd ich sagen, oder?


    Hinten stehen jetzt die Spitzen der Schrauben raus:


    20191019_223648.jpg


    Dort muss ich dann noch Kabel anlöten, alles sauber isolieren und dann muss man das Ganze nur mehr richtig an das Display anschließen und hat eine perfekte Ganganzeige um ein paar Euro :Daumen hoch:


    Den Leerlauf sollte man aber unbedingt, zusätzlich zur Ganganzeige auch am originalen Stecker wieder anschließen, da erstens sonst die Leerlaufkontrollleuchte im Kombiinstrument nicht mehr funktioniert und zweitens dann ohne gezogener Kupplung auch nicht mehr gestartet werden kann.

    Den 2ten und den 3ten Gang muss man nicht mehr zwingend zusätzlich zur Ganganzeige auch am originalen Stecker wieder anschließen, aber wer zu 100% legal unterwegs sein will der sollte das trotzdem machen, da ansonsten die Betriebserlaubins vom Moped erlischt.


    Wenn Fragen sind, nur raus damit

    Gruß, Martin

    9 Mal editiert, zuletzt von Weity1980 ()

  • So, jetzt sollten die Bilder wieder funktionieren.


    Ich fand die Idee wirklich so genial, da musste ich das einfach mal testen.


    Nix kalibrieren, nicht mehr warten bis aus Drehzahl und Geschwindigkeit der Gang berechnet wurde, einfach schalten und es wird dir der Gang schon angezeigt noch bevor du die Kupplung überhaupt losgelassen hast.


    Also ich find's echt genial.


    Hoffe es funktioniert dann auch :lautlach:

    Gruß, Martin

  • Hab heute übrigens mal einen "Trockentest" am ausgebauten Motor mit einer Glühbirne als Verbraucher gemacht.


    Funzt alles bestens :Daumen hoch:

    Jetzt muss nur noch die Anzeige kommen.


    Werde dann berichten

    Gruß, Martin

  • Wie funktioniert eigentlich die Ganganzeige bei der 701 Vitpilen?


    Könnte man von dort ein PlugNplay Ersatzteil in die neue SMC R pflanzen und mit einem Zusatz Display verbinden?

    2019 SMC R

  • Das war aber ehrlich gesagt nur so eine Hauruck Aktion ohne dass ich mir vorher großartig Gedanken darüber gemacht habe wie ich das letzendlich wirklich umsetze.

    Ich hab auch zuerst einfach mal gebohrt und mir dann erst überlegt was ich da jetzt überhaupt als Kontakt reinschrauben könnte 🙈


    Aber vom Grundprinzip her passt das glaub ich eh schon mal nicht so schlecht.


    Aber vielleicht hat ja auch jemand ne Idee wie man das noch besser machen könnte.


    Ich hab ja noch einen 2ten Motor und somit auch einen 2ten Gangsensor zu Hause, also war's mir ehrlich gesagt auch nicht so wichtig gleich ein perfektes Ergebnis zu haben, sondern ich wollte es einfach nur mal testen ob's überhaupt geht

    Gruß, Martin

  • Ich bin zwar in der glücklichen Lage bei meiner V (er) Duke eine Ganganzeige im Display zu haben aber ich finde es immer genial wenn sich jemand hinsetzt und sich absolut uneigennützig für andere die Mühe macht das Umgesetzte zu dokumentieren!

    Tolle Arbeit Weity1980 und weiter so!!!

  • Hatte ursprünglich auch angedacht dann ein M3 oder M4 Gewinde zu schneiden und eine passende Schraube zu nehmen, aber dann sind mir die Messing Holzschrauben untergekommen und ich dachte das könnte doch eigentlich auch ganz gut passen.

    Vorallem hat ja auch nicht jeder einen M3 oder M4 Gewindeschneider zu Hause und bei den Holzschrauben erspart man sich auch das Gewinde schneiden.


    Aber natürlich wärs auch cool andere Varianten zu sehen und dann kann jeder, der sich auch so eine Ganganzeige machen möchte, selbst entscheiden wie er es dann am liebsten umsetzen möchte.


    DukeSW Danke für das Lob. Aber wie gesagt, die Idee dazu stammt nicht von mir, sondern ich wurde nur durch diese Seite dazu inspiriert. Es kann aber jeder, der sich so eine Ganganzeige bastelt dann dort ein Lob hinterlassen!

    Reiner von on2r.eu würde sich sicher über jedes einzelne Feedback zu seiner Idee freuen :ja:


    Ich fand die Idee halt nur so grenzgenial, dass ich es einfach mal testen musste und das wollte ich euch natürlich auch nicht vorenthalten

    Gruß, Martin

  • Man könnte ein gewinde schneiden und eine Maschinenschraube von außen rein Schrauben. Die brauch man dann nicht/wenig abschleifen.

    Oder kleine Madenschrauben oder Kreuzlochschrauben (kann man schön Kabel durchlegen), dann hat man mehr platz, da der große Kopf der schraube wegfällt. ... Hachjaa so viele tolle Möglichkeiten.

  • Hai.

    Super Bericht. Könnte man eigentlich auch hier wieder Led's an die Kabel für den 2+3 Gang so anschließen, dass die entsprechend leuchten, wenn der Gang eingelegt ist. Gab es früher mal bei Gangsensor auspinnen einen Threat zu.

    Welche Kabel gehören zum 2. bzw. 3. Gang?

    (so wie hierhttps://www.ktmforum.eu/forum/thread/78586-gangsensor-auspinnen-und-anzeige-f%C3%BCr-2-3-gang-basteln/?postID=1046253#post1046253 )

    Danke

    Frank

    Jetzt: 690 Enduro R Bj. 2019. Davor 690 Enduro Bj. 2013. Davor 690 SMC, früher: LC 4, Bj 2003, Tuning Feder + Nadel, Akrapovic komplett ......

  • Hallo Frank

    Ja klar könntest du auch hier wieder LEDs anschließen die dir den 2ten und/oder 3ten Gang anzeigen.

    Wenn du aber nur ein optisches Signal benötigst um zu wissen ob du den 2ten oder 3ten Gang drinnen hast, dann brauchst du den Gangsensor dafür nicht umbauen sondern dann genügt es auch einfach die originalen Anschlüsse zu verwenden.


    Der Gangsensor schaltet die einzelnen Anschlüsse je nach eingelegtem Gang ja einfach nur auf Masse.

    Also eine oder zwei 12V LEDs irgendwo im Cockpit installieren, Zündungsplus drauf und die Masse der LEDs über das entsprechende Kabel am Gangsensor laufen lassen.


    Die originalen Kabelfarben sind wie folgt:


    Grün: Neutral

    blau/rot: 2ter Gang

    grün/gelb: 3ter Gang


    20191021_161852.jpg

    Gruß, Martin

  • So schauen übrigens die Pins aus die auf den Gangsensor drücken:


    20191021_155723.jpg


    20191021_155730.jpg


    Wie gesagt, die sind einfach nur reingesteckt und durch eine kleine Feder vorgespannt.

    Der äußere Pin dreht sich gegen den Uhrzeigersinn einfach immer weiter wenn man hochschaltet.


    Dadurch wird dann der entsprechende Kontakt am Gangsensors einfach vom äußeren über den mittleren Pin auf Masse zum Motorgehäuse geschalten, da der mittlere Pin ja durch das schwarze Kabel am Gangsensor, welches mit einer Schraube des Gangsensor mitgeschraubt wird, Kontakt zum Motorgehäuse hat.


    Klingt vielleicht kompliziert, ist es aber nicht.


    Darum wäre es auch für KTM ohne großartigen finanziellen Mehraufwand eine Leichtigkeit gewesen, gleich ab Werk alle 690iger mit einem Gangsensor auszustatten. Versteh nicht warum sie das nicht gemacht haben 🤷🏼‍♂️

    Gruß, Martin

    Einmal editiert, zuletzt von Weity1980 ()

  • frankms

    Hab mir jetzt auch mal diesen Thread hier durchgelesen.

    Ich finds echt lustig dass es auch vor 10 Jahren im Forum schon so sinnlose und unnütze Diskussionen gab :lol:

    Kommt mir irgendwie bekannt vor :grins:


    Und ich glaub jene die einfach nicht checken wofür jemand eine LED haben will, die ihm im Augenwinkel signalisiert wann beim Runterschalten im Angriffsmodus der 2te oder ggf. der 3te Gang drinnen ist, der ist wohl noch nie wirklich im Angriffsmodus unterwegs gewesen.


    Just my two cents

    Gruß, Martin

  • Zitat

    Darum wäre es auch für KTM ohne großartigen finanziellen Mehraufwand eine Leichtigkeit gewesen, gleich ab Werk alle 690iger mit einem Gangsensor auszustatten. Versteh nicht warum sie das nicht gemacht haben 🤷🏼‍♂️

    Naja, damals, vor gut 10 Jahren wars ja noch nicht Standard. Später dann hamse ohnehin für alle nachgerüstet, wenngleich ich persönlich bei meiner die Displaylösung nicht gut finde, da es an der Ablesbarkeit mangelt.

  • Ist auch schon wieder 9 Jahre her, unglaublich.

    Funktioniert übrigens immer noch einwandfrei.

  • ...wenngleich ich persönlich bei meiner die Displaylösung nicht gut finde, da es an der Ablesbarkeit mangelt.

    Die Erfahrung hab ich auch gemacht als ich mal eine KTM Probe gefahren bin welche ab Werk die Ganganzeige im Display hatte.

    War nicht so meins... :nein:

    Wenn man schon eine hat, dann sollte man sie auch schnell und klar ablesen können


    20190831_194436.jpg

    Gruß, Martin