Drosselklappen - Sensor Einstellung nur 91% voll offen

  • Hallo, ich würde das Thema gern wieder aufwärmen.

    Ich besitze ebenfalls seit einigen Jahren ein KTM 990 Smt, welche mir viel Spass macht.

    Allerdings ist nun bei mir nach ca. 28000km Laufleistung ebenfalls ein Leerlaufdrehzahlproblem wiederholt aufgetreten. Es fing nach dem Winterschlaf vor zwei Jahren an, daß das Standgas auf einmal höher lief.

    (im Kalten Zustand bei 2200-2500 U/min wenn war dann bei 3000-3200 u/min) Somit habe ich keine keine Motorbremse mehr und die Maschine läuft z schnell heiß.

    Das Problem trag zu Anfang für 1 Woche auf, und verschwand dann für 500km.

    Das Problem kam regelmäßig wieder und lies mir allerdings jetzt eine ganze Saison Ruhe...bis jetzt.


    Ich möchte natürlich ungern eine neue Komplette Drosselklappe für 1000Euro+ kaufen wenn ich vielleicht nur einen der Sensoren tauschen muss.


    Kann mir bitte einer von euch bei der systematischen Fehlersuche behilflich sein.

    Wie kann ich in welcher Reihenfolge vorgehen?


    Ich habe das OPD Kabel für KTM so wie einen OPD2 mit Bluetooth und dank des Users duccud, auf die Tune ECU Software für Windows.

    Der Tank ist Demontiert und die Drosselklappe Sichtbar


    Im voraus schon einmal vielen Dank


    Beste Grüße Peter

  • Guten Abend, hab mich die Wochen nun mal mit der Drosselklappeneinheit beschäftigt und den oberen Drosselklappensensor als defekt identifiziert. Das habe ich dank einer Rauschprüfung mittels eines Oszilloskops ermittelt. Hab den Sensor daraufhin ausgesägt und ein vertrautes Schadbild gesehen, welches ich bereits hier im Forum bei einem anderen User gesehen hatte. Den Sensor hab ich ersetzt, der Fehler mit der zu hohen Drehzahl bleibt aber weiter unverändert bestehen. Muss ich noch irgendwas beachten, Software neu aufspielen oder so?

    Beste Grüße Peter

  • Fehler löschen, Batt. für 15min. abhängenund dann mal ini-lauf machen; sollte dann weg sein!

    sofern der sensor richtig montiert/positioniert ist/wurde

    und immer sind es die anderen die die Idioten sind, nur

    man bedenke auch selbst ist man für jeden der Andere :staun: :denk: :denk:

  • WhitePoint


    hast du den poti mit tune ecu auf die vorgeschriebene spg eingestellt > beitrag 1


    • soll= 0,56...0,64V laut WHB, kontrollieren mit der anzeige in Tune Ecu im diagnosemodus
    • dann fehlerspeicher löschen und auf ausgangswerte zurück setzen.
    • INI lauf

  • Danke für die Hinweise, hab nichts davon getan. Mein Opd2 Adapter ist leider ungeeignet, wie ich recherchiert habe. Da muss ich wohl erstmal noch 70€investieren. Danke auf jeden Fall

  • Ein Mitarbeiter von der KTM Werkstatt, den ich mein Problem geschildert habe, meinte zu mir " wenn im Display kein Fehler angezeigt wird, liegt auch keiner vor den man zurück setzen könnte". Hat er eigentlich recht. Er sagt das auf jeden Fall der Stellmotor der Leerlaufdrosselklappe erledigt ist, der schafft es nicht mehr die Klappe zu Bewegen. Ist ein wirklich häufiges Problem, da die Drosselklappenmechanik mit der Zeit schwergängiger wird und der Motor einfach unterdimensioniert ist.

    Den gibt es natürlich nicht einzeln zu kaufen und die gebrauchten im Netz dürften wahrscheinlich alles Defekt sein.


    Ich hab die Klappe heute ausgebaut und mir nochmal angeschaut....der Motor(SHP-35D1004) scheint ebenfalls in einer Suzuki GSXR750 verbaut zu sein.

    Der Mechanismus als solcher sieht einwandfrei aus und fühlt sich in der Beweglichkeit auch nicht schwergängig an....allerdings habe ich natürlich keinen vergleich.


    Habt ihr noch Ideen?

  • also wenn ein ma einer Werkstatt sowas erzählt dann weiss ich leider nicht was er bei ktm tut!!!!!

    z.b. ini läufe und deren Notwendigkeit werden auch nicht gespeichert und dennoch korrigieren sie!!!

    aber was solls es gibt immer wieder eggsberten!!!!


    da du offensichtlich schon beim basteln bist, die Stellmotoren gehen oder sind defekt, dazwischen gibts nix;

    hol dir noch die nötigen tps Sensoren und baue sie ein; dann mach dir die Arbeit und justiere sie entsprechend den bereits genannten werten;

    dazu ist natürlich tune ecu notwendig;

    alles mit ruhe und der nötigen Genauigkeit; du wirst erfolgreich sein und deine:grins::grins: um so grösser:peace::peace:

    und immer sind es die anderen die die Idioten sind, nur

    man bedenke auch selbst ist man für jeden der Andere :staun: :denk: :denk:

  • jetzt nochmal ne Frage zu dem OPD Adapter, muss ich mir für meine KTM einen OPTlink MX/LX Adapter holen, oder reicht auch ein einfacher aus? Die Dinger sind zum einen schwierig in Europa zu bekommen wie mir scheint, zum anderen sind sie auch sehr Teuer.

    In der Anleitung von Tune ECU steht das nur explizit für Triumph Motorräder ein solcher gebraucht wird.


    Könnt Ihr mir einen empfehlen...ggf. gleich mit link?

    Einmal editiert, zuletzt von WhitePoint ()

  • Bei meiner 990er waren es auch nur 93%, hatte die Sekundärklappen entfernt, mit TuneECU durch die Unterdruckanzeige die Droosselklappen synchronisiert und den Anschalg mit dem Dremel so langen bearbeitet bis ich die 100% hatte:wheelie:

  • Könnt Ihr mir einen empfehlen...ggf. gleich mit link?

    https://www.amazon.de/gp/product/B00EY7Y6CI/ref=ppx_yo_dt_b_search_asin_image?ie=UTF8&psc=1


    Ist die günstigste Lösung, von der ich weiß, dass sie mit TuneECU, KTM, Ducati (Magnet Marelli) und PC bzw Android-Geräten funktioniert.

    Letztere brauchen dann noch einen OTC-Adapter von USB auf das passende UBS (meist Micro oder C).

    Knuckles: KTM SD 990 (06) // Feuerrotes Spielmobil: Ducati Hypermotard 1100S (07) // Diva: Ducati Shyster (Supersport meets ST3)